2D Geometry CAD Tools with SVOffice™ 2009


Presented by: Dr. Murray Fredlund, President of SoilVision Systems Ltd.

Introduction

Hi, my name is Murray Fredlund. Welcome to the session 2D Geometry Basic CAD Drawing Tools within the SVOffice 2009 Next Generation Geotechnical software suite.

Outline

This presentation will provide the user with an understanding of working with the grid, entering editing and drawing geometry, both from the keyboard and graphically, as well as basic drawing tools such as snapping to shape points, moving points, deleting points, and moving objects. Once the user has completed this presentation they should have a basic understanding of how to manipulate objects graphically on the CAD window in the SVOffice software.

Working with the Grid

One of the first things the user must do when setting up model is decide what a reasonable grid size is. The grid defines the smallest resolution at which coordinates can be entered on the CAD Window. As an example of this, if the smallest grid setting is 0.5 then the coordinate points can only be entered at intervals of 0.5. The lower left corner of the world coordinate system defines the starting coordinate for the grid spacing.

If the user chooses a reasonable grid size it makes it very easy for the user to draw geometry of the screen. The grid spacing is found under the View > Display Options menu. The Display Options dialog is also displayed when the model is first created. A good rule of thumb for grid spacing for numerical modeling is approximate 1-5% of the world coordinate system range in the longest direction. Ideally your grid spacing should be set as the smallest cordinate and resolution which the user decides to capture within the numerical model.

As an example of this we can suppose that the following earth dam shape is desired to be created in the software. If we were to draw the shape without a grid than it is difficult to get the coordinates to fall exactly at 1,1 or exactly at a coordinate of 6.5,7. However if we take a quick look over the geometry we can see that the smallest coordinate resolution is one half of a meter. Therefore if we set the grid resolution to 0.5 m then this will allow us to draw the earth dam in a reasonable fashion on the CAD control window.

In this example I have pre-created the simulated earth dam in the software and drawn an artwork shape which represents a trace of the final object.in this case we must ensure that the grid options are set properly. If I open the display options dialog we can see that the horizontal and vertical spacing of the grid is set at 0.5 m. This is acceptable and we will leave it as is. We will also confirm that the grid is shown and that we are going to snap to the grid. There are currently no other objects on the chat window therefore we do not need to snap to any other object points.

Once we close the display options dialog we can proceed with drawing the shape. It can be seen that when snapping his properly enabled the drawing of such a shape is quite easy. Once the region is drawn the user can right-click on the final point and complete drawing of the polyline shape.

Entering Geometry

It is important to note that all geometry must be entered within the context of the current world coordinate system.

Geometry can be entered into the software in a number of different ways. It can be drawn directly using the CAD interface tools provided. Geometry can also be cut and pasted from other software packages such as Microsoft Excel. It's also possible to manually type in the coordinates in the user interface.

Lastly geometry can be imported from a number of file formats including AutoCAD DXF files or ESRI shape files. When importing AutoCAD files there are a number of smart algorithms which run in the background to close polygons which are not closed or to import partial polygons which form the basis of layered systems.

These geometry tools are provided to allow reasonable flexibility when the user is entering numerical models in the software.

It is worth noting that all functions related to entering and editing geometry may be found under the Model > Geometry menu as shown in the picture on this slide. The menu items may change slightly between packages but all geometry related functions will always be included under this menu option. Next we would like to show you a simple graphical example of geometry being entered in the SVOffice software package.

In this example we will open the SVOffice software and illustrate the basic ways with which geometry can be entered into the software. Geometry can be entered in a number of different ways:

  1. By drawing it directly using the CAD tools provided,
  2. By cutting and pasting geometry data from other software packages such as Microsoft Excel,
  3. By manually typing in the coordinates, and
  4. By importing geometry from an AutoCAD DXF file, or
  5. Importing from an ESRI shape file.

Drawing Geometry

The draw menu in the software handles the functions which specifically allow geometry to be drawn directly onto the CAD control of the software. Specific menu options will vary with each package in that there are different objects which can be drawn. An example of this is the SVSlope software which allows additional objects to be drawn on the CAD control. The draw menu item is generally simpler with the finite element packages.

Editing Geometry Objects

The design cycle for most engineering firms dictates that a number of different design scenarios need to be tried in order to determine which scenario is the best. This means that often the geometry for a particular model must be altered many times through the design cycle. This ability to rapidly alter or edit geometry is a significant feature of the SVOffice software. The SVOffice software implements a highly visual model design environment. Therefore the user may enter and edit any graphic object both through the use of the keyboard or through graphical measures such as:

  • Double-clicking on the object, or
  • Graphically editing objects in the CAD window (covered later), or
  • Right-clicking on the object and selecting the desired function from the menu list.

It is expected that the user may want to:

  • Snap to shape points
  • Move a shape point
  • Move multiple shape points
  • Move a shape
  • Add points to a shape
  • Cut a line segment
  • Delete a shape point

All these functionalities are provided in the SVOffice software and the following demo will illustrate how to perform each of these functions.

In this example we will examine a number of functions by which we can edit and revise geometry.

If the user desires to add a new shape to numerical model it is necessary that the new points join exactly with existing shapes. Therefore in the present example we're going to add a layer on the left-hand side of the earth dam and we want to snap exactly to the previously entered points on the sand shape. We also want the additional points to snap to the grid so we will leave both the grid snapping and objects mapping turned on.

Once we have drawn a new shape we might find that a shape point was entered incorrectly. In this case we want to move a shape point. It is certainly easy to right-click on the shape and enter or adjust the node points from the keyboard however we can do this graphically by holding down the control key and clicking on a shape point and moving it graphically. If grid snapping is on then the node point will snap to the nearest grid point as well.

It may also be useful to move multiple points on a shape. This can easily be accomplished in the software by selecting multiple points and then holding down the control key and moving the group of points. Any particular action can be undone under the Edit > Undo menu option.

Alternatively an entire shape can be moved by selecting the shape and holding down the shift key and dragging the mouse in the desired direction.

If the user wants to add points to a given shape it is easiest to open the region properties dialog and add the point manually. This can be accomplished through the Insert button located on the dialog.

Alternatively the user should be aware that they can cut any particular line segment by i) selecting the line segment, and then ii) pressing the Insert key to insert a point, and then iii) dragging the mouse to the desired location to insert a point and cut the line segment.

Any points can be deleted from a region either from within the region dialog or graphically by using the right-click menu options.


Return to the video tutorials listing