Basic Concepts with SVOffice™ 2009


Presented by: Dr. Murray Fredlund, President of SoilVision Systems Ltd.

Introduction

Hi, my name is Murray Fredlund and welcome to the session on Basic Concepts within the SVOffice 2009 Next Generation Geotechnical software suite.

Background on the Software

The SVOffice geotechnical software suite is essentially made up of three modules: Front End, Solver and Back-End Visualization. The Front End module allows the user the nice graphic interface to design their model. The Solver provides the analytical solution to the posed problem and the AcuMesh Back-End Visualization module allows the user to see the results in a format that is meaningful. This software is designed to integrate all three modules such that the user may not even be aware of transitioning between the three modules. This is all part of the seamless interface that makes up SVOffice.

Negotiating Through the Software Menus

Once the user opens a numerical model in the SVOffice package, they will notice a variety of menus, toolbars, the main CAD display screen and a few objects on the screen. What I want to first talk about is the organization of the screen. Here you have toolbars which speed up certain common tasks with the numerical model such as the main menu system. If you click on any of the top menus, they drop down to display relevant action items. On the left hand side of the screen there is a toolbar that allows switching between the main manager and any numerical model. You can also switch between the front end and the back end (which is reached by clicking the AcuMesh icon). As well, for the help of the user, there is a side tutor bar (on the right hand side of the page) which outlines the main modeling steps someone would take in designing their first model. Clicking on any of the hyperlinks will bring up additional Help.

Menu Flow

Another important thing to realize about this software is that the menus are laid out in a left to right and top to bottom design. What this means is that if a user goes through the menu items in such a manner, they will be guided through the creation of a typical numerical model. There will be many options that a user may not need for their first model and because of this, most of the modeling options that a general user might need are located on the Model menu. If the user opens the Model menu the biggest items are the Geometry of the model, Initial Conditions, Supports, Loading Conditions, and how you want to search for your Slip Surface. The Draw menu offers a variety of ways to input graphic objects (discussed in other tutorials). Solve allows you to analyze the numerical model and view the results. The user can also adjust the settings of the model under the View tab. Settings changes include Aspect Ratio and Constraining in the X and Y direction. Various Display options such as Showing the Grid and Snapping the Grid can be selected. As well, the World Coordinate System can be specified to detail the overall map of coordinates within which your model should fall.

CAD Control

Another basic idea of the software is that everything is an object within the CAD control. The CAD control window contains the graphic display of current objects. The concept is that if the user clicks on any particular objects and right-clicks they bring up any relevant properties which affect the current object. For example, in a numerical model one can apply loading conditions, can delete the polygon, apply a material to that region or get help on that region. As well, the user should be aware that all of the basic functionality for drawing, editing objects, moving objects, etc. can be found under the Help menu. Issues such as Snapping, Moving points, Deleting points, Moving shapes, etc. can all be displayed.


Return to the video tutorials listing